martes, 19 de septiembre de 2017

Instalación de GNS3 Windows Dynamips




Instalación de GNS3 Windows Dynamips, que es parte del curso de "Fundamentos de GNS3 - Simulador Grafico de Redes de Datos" El curso cuenta con: 1. Introducción 2. Primeros pasos en GNS3 Dynamips 3. Usando GNS3 VM 4. Conexión GNS3 a Internet y habilitación de NAT 5. Captura de tráfico con Wireshark en GNS3 6. Proyecto final con GNS3 7. Actividad de Configuración GNS3 Y mucho mas en:
http://bit.ly/2w5Y91r

viernes, 7 de abril de 2017

Captura de la clave TELNET con GNS3 y Wireshark

Hola, en este vídeo revisaremos como capturar la clave de Telnet, utilizando el emulador de redes avanzadas GNS3 y la herramienta de captura de tráfico Wireshark

Este vídeo es parte del nuevo curso de "Fundamentos de GNS3 - Simulador Grafico de Redes de Datos"




Síguenos también en:


Facebook | Twitter | Google + Youtube Cursos





Regístrate a nuestros contenidos

* indicates required



martes, 21 de febrero de 2017

Configurar y verificar la conectividad de single-homed branch usando IPv4 eBGP (CCNA 200-125)


Configurar y verificar la conectividad de single-homed branch usando IPv4 eBGP (CCNA 200-125)


Diagrama







Objetivos

  • Configuración de eBGP
  • Verificar conectividad
  • Revisión de comandos para verificar y solucionar problemas eBGP


Conceptos

  • BGP ( Border Gateway Protocol), se define en el RFC 1771 , y es un protocolo que se utilizan en los nodos de Internet el cual intercambian información de encaminamiento o ruteo entre sistemas autónomos (AS). 
  • Un sistema autónomo es un conjunto de routers bajo una sola administración técnica
  • BGP tiene como misión encontrar el camino más eficiente entre los nodos para propiciar una correcta circulación de la información en Internet.
  • Dos routers cualquiera que formen una conexión TCP para intercambiar información de enrutamiento BGP son "pares" o "vecinos“
  • Cuando BGP se ejecuta entre routers que pertenecen a dos AS diferentes, recibe el nombre de BGP externo (eBGP). Cuando BGP se ejecuta entre routers del mismo AS, recibe el nombre de iBGP.

Configuración – Tabla Direccionamiento IP







Configuración Router1

  • Router1(config)# interface Loopback0
  • Router1(config-if)# ip address 1.1.1.1 255.255.255.0
  • Router1(config-if)# interface GigabitEthernet0/0
  • Router1(config-if)# ip address 1.1.2.1 255.255.255.252 
  • Router1(config)# router bgp 100
  • Router1(config)# neighbor 1.1.2.2 remote-as 200
  • Router1(config)# network 1.1.1.0 mask 255.255.255.0
  • Router1(config)# exit
  • Router1# copy run star

Configuración Router2

  • Router2(config)# interface Loopback0
  • Router2(config-if)# ip address 1.1.3.3 255.255.255.0
  • Router2(config-if)# interface GigabitEthernet0/0
  • Router2(config-if)# ip address 1.1.2.2 255.255.255.252 
  • Router2(config)# router bgp 200
  • Router2(config)# neighbor 1.1.2.1 remote-as 200
  • Router2(config)# network 1.1.3.0 mask 255.255.255.0
  • Router2(config)# exit
  • Router2# copy run star


Verificación de conectividad

  • Ping desde Router1 a Router2 (1.1.3.3)
  • Ping desde Router2 a Router1 (1.1.1.1)
Resultados, con respuesta satisfactoria:
Router1#ping 1.1.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

Router2#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms


Revisión de comandos para verificar y solucionar problemas de eBGP

  • show ip bgp
  • show ip bgp neighbors
  • show ip bgp summary
  • show ip route bgp
Resultados de verificación:
Router1#sh ip bgp
BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.0/24 0.0.0.0 0 0 32768 i
*> 1.1.3.0/24 1.1.2.2 0 0 0 200 i 


Router1#sh ip bgp neighbors
BGP neighbor is 1.1.2.2,  remote AS 200, external link
  BGP version 4, remote router ID 1.1.3.3
  BGP state = Established, up for 00:10:39
  Last read 00:10:39, last write 00:10:39, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                1          1
    Keepalives:            11         11
    Route Refresh:          0          0
    Total:                 13         13
  Default minimum time between advertisements runs is 30 seconds
 For address family: IPv4 Unicast
  BGP table version 3, neighbor version 6/0
  Output queue size : 0
  Index 1, Offset 0, Mask 0x2
  1 update-group member
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               1          1 (Consumes 46 bytes)
    Prefixes total:                 1          1
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          1
    Used as multipath:            n/a          0
                                       Outbound    Inbound
      Local Policy Denied Prefixes:    --------    -------
        Total:                                0          0
      Number of NLRIs in the update sent: max 3, min 1
  Address tracking is enabled, the RIB does have a route to 1.1.2.2
  Connections established 1; dropped 0
  Last reset never
  Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Minimum incoming TTL 0, Outgoing TTL 1
Local host: 1.1.2.1, Local port: 179
Foreign host: 1.1.2.2, Foreign port: 1025
Connection tableid (VRF): 0
Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)
Event Timers (current time is 0xC69F4):
Timer          Starts    Wakeups            Next
Retrans             0          0             0x0
TimeWait            0          0             0x0
AckHold            12          0             0x0
SendWnd             0          0             0x0
KeepAlive          11          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0
Linger              0          0             0x0
ProcessQ            0          0             0x0
iss: 2057115318  snduna: 2057115748  sndnxt: 2057115748     sndwnd:  15955
irs: 3480424370  rcvnxt: 3480424751  rcvwnd:      16004  delrcvwnd:    380
SRTT: 259 ms, RTTO: 579 ms, RTV: 320 ms, KRTT: 0 ms
minRTT: 16 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: passive open, gen tcbs
Option Flags: nagle, path mtu capable
IP Precedence value : 6
Datagrams (max data segment is 1460 bytes):
Rcvd: 13 (out of order: 0), with data: 0, total data bytes: 0
Sent: 12 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 1, total data bytes: 24
 Packets received in fast path: 0, fast processed: 0, slow path: 0
 fast lock acquisition failures: 0, slow path: 0 

Router1#sh ip bgp summary
BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 3, main routing table version 6
2 network entries using 264 bytes of memory
2 path entries using 104 bytes of memory
1/1 BGP path/bestpath attribute entries using 184 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 632 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer  InQ OutQ Up/Down    State/PfxRcd
1.1.2.2      4 200       15             14     3            0      0          00:12:05        4

Router1#sh ip route bgp
B     1.1.3.0/24         [20/0]        via         1.1.2.2,    00:14:49



Cualquier duda, solo escribela en este blog y será respondida.

Para un curso completo sobre este tópico y otros del CCNA 200-125, puedes encontrarlo acá





Síguenos también en:


Facebook | Twitter | Google + Youtube Cursos





Regístrate a nuestros contenidos

* indicates required




sábado, 11 de febrero de 2017

Configuración de direccionamiento IPv4 y subredes

Veremos los conceptos básicos de direccionamientos IP, y una práctica de red con una topología real de redes de datos, verificaremos su funcionamiento y revisaremos los comandos para ver su funcionamiento.

2.1 Objetivos


·        Práctica de direccionamiento IP
·        Práctica de VLSM
·        Práctica de sumarización de rutas
·        Revisión de comandos para verificar y solucionar problemas de direccionamiento IPv4

2.2 Conceptos de IPv4


2.2.1 Convertir de decimal a binario






   

Para convertir un número decimal a un número binario, se deben activar los bits en 1, hasta alcanzar el número decimal deseado, por ejemplo:

              192 = 11000000 = 128+64 à Nro. Decimal = 192 à  Nro. Binario = 11000000
168 = 10101000 = 128 + 0+ 32+ 0 + 8 à Nro. Decimal = 168 à  Nro. Binario = 10101000
               221 = ¿Cuál es el número binario?


2.2.2 Convertir de binario a decimal

Para convertir un número binario en decimal, se deben agregar los bits que se han activado (1s), por ejemplo:
             10101100 = 128 + 0 + 32 + 0 + 8 + 4 = 172
             00010000 = 0 + 0 + 0 + 16
             10101010 = ¿Cuál es el número decimal?



2.2.3 Cálculo de subredes VLSM

Creación de subred de 30 host – Red base 192.168.0.0
Fórmula cálculo de host à 2n – 2 ≥ 30 à n=5 à 25  - 2 = 32 – 2 = 30 host
Máscara à 11111111.11111111.11111111.11100000 (24 bit de red + 3 bit de subred + 5 bit de host (bits en 0))
Máscara à 255.255.255.224

Creación de subred con 14 host – Red base 192.168.0.0
Fórmula cálculo de host à 2n – 2 ≥ 14 à n=4 à  24  - 2 = 16 -2 = 14 host
Máscara à 11111111.11111111.11111111.11110000 (24 bit de red + 4 bit de subred + 4 bit de host (bits en 0))
Máscara à 255.255.255.240

Creación de subred con 62 host – Red base 192.168.0.0 (¿Cuál es la máscara?)
Fórmula cálculo de host à 2n – 2 ≥ 62 à n=? à  2?  - 2 = ? -2 = 62 host
Máscara à 11111111.11111111.11111111.???????? (24 bit de red + ? bit de subred + ? bit de host (bits en 0))
Máscara à 255.255.255.?




2.2.4 Resumen subred IPv4





   2.2.5 Sumarización de rutas:

Es una técnica empleada para agrupar múltiples rutas IP contiguas en una única ruta, de tal manera de reducir la cantidad de rutas en una tabla de enrutamiento de un router, aumenta la estabilidad ya que permanece estable mientras al menos una de las rutas sumarizadas permanezca activa, además reduce la cantidad de memoria RAM y procesador  usada en la tabla de enrutamiento.

Un ejemplo de sumarización de rutas:

            172.16.0.0/24 = 10101100.00010000.00000000.000000000 à Ruta presente en red local
            172.16.1.0/24 =10101100.00010000.00000001.000000000 à Ruta presente en red local
            172.16.2.0/24 =10101100.00010000.00000010.000000000 à Ruta presente en red local
   172.16.3.0/24 =10101100.00010000.00000011.000000000 à Ruta presente en red local
Bit común:   10101100.00010000.000000 --> /22
Ruta sumarizada y publicada hacia el exterior:
172.16.0.0/22

Realice la siguiente práctica de sumarización de rutas:
10.0.0.0/24 =
10.0.1.0/24 =
10.0.2.0/24 =
10.0.3.0/24 =
10.0.4.0/24 =
10.0.5.0/24 =
10.0.6.0/24 =
10.0.7.0/24 =
Bit común: ?.?.? à /?
Ruta sumarizada y publicada hacia el exterior:
10.0.?.?/?



2.3 Práctica de IPv4


Las prácticas de este libro fueron realizadas con “Cisco Packet Tracer”, si deseas saber más de Packet Tracer, te dejo este link para un video curso con un descuento especial por haber adquirido este libro.


2.3.1 Diagrama topológico:






2.3.2 Configuración – Tabla de Direccionamiento IP





2.3.3 Configuración Router1

Router>ena
Router# config t
Router(config)#hostname Router1
Router1(config)#enable secret cisco
Router1(config)#line console 0
Router1(config-line)#login
Router1(config-line)#password cisco
Router1(config-line)#exit
Router1(config)#line vty 0 15
Router1(config-line)#login
Router1(config-line)#password cisco
Router1(config-line)#exit
Router1(config)# interface FastEthernet0/0
Router1(config-if)# ip address 192.168.0.1 255.255.255.224
Router1(config-if)# interface FastEthernet0/1
Router1(config-if)# ip address 192.168.0.33 255.255.255.240
Router1(config-if)# interface FastEthernet1/0
Router1(config-if)# ip address 192.168.0.49 255.255.255.248
Router1(config-if)# interface Serial0/0
Router1(config-if)# ip address 192.168.0.57 255.255.255.252
Router1(config-if)#exit
Router1(config)# ip route 172.16.0.0 255.255.252.0 192.168.0.58
Router1(config)#exit
Router1# copy running-config startup-config


2.3.4 Configuración Router2

Router>ena
Router# config t
Router(config)#hostname Router2
Router2(config)#enable secret cisco
Router2(config)#line console 0
Router2(config-line)#login
Router2(config-line)#password cisco
Router2(config-line)#exit
Router2(config)#line vty 0 15
Router2(config-line)#login
Router2(config-line)#password cisco
Router2(config-line)#exit
Router2(config)# interface FastEthernet0/0
Router2(config-if)# ip address 172.16.0.1 255.255.255.0
Router2(config-if)# interface FastEthernet0/1
Router2(config-if)# ip address 172.16.1.1 255.255.255.0
Router2(config-if)# interface FastEthernet1/0
Router2(config-if)# ip address 172.16.2.1 255.255.255.0
Router2(config-if)# interface Serial0/0
Router2(config-if)# ip address 192.168.0.58 255.255.255.252
Router2(config-if)# exit
Router2(config)# ip route 192.168.0.0 255.255.255.224 192.168.0.57
Router2(config)# ip route 192.168.0.32 255.255.255.240 192.168.0.57
Router2(config)# ip route 192.168.0.48 255.255.255.248 192.168.0.57
Router2(config)# exit
Router2# copy running-config startup-config


En el Router2 podemos sumarizar las redes de la siguiente forma:

192.168.0.0/27  à 11000000. 10101000.00000000.00000000
192.168.0.32/28 à 11000000. 10101000.00000000.00100000
192.168.0.48/29 à 11000000. 10101000.00000000.00110000
Bit común:   11000000. 10101000.00000000.00 --> /26
Ruta sumarizada y publicada hacia el exterior:
192.168.0.0/26


Por lo que podemos crear una única ruta hacia estas tres redes, de la siguiente forma:

Router2(config)# no ip route 192.168.0.0 255.255.255.224 192.168.0.57
Router2(config)# no ip route 192.168.0.32 255.255.255.240 192.168.0.57
Router2(config)# no ip route 192.168.0.48 255.255.255.248 192.168.0.57
Router2(config)# ip route 192.168.0.0 255.255.255.192 192.168.0.57 à Ruta sumarizada
Router2# copy running-config startup-config


2.3.5 Configuración de PC

PC0
IP:                                     192.168.0.10
Máscara de subred:      255.255.255.224
Default Gateway:         192.168.0.1

PC1
IP:                                     192.168.0.42
Máscara de subred:      255.255.255.240
Default Gateway:         192.168.0.33

PC2
IP:                                     192.168.0.54
Máscara de subred:      255.255.255.248
Default Gateway:         192.168.0.49

PC3
IP:                                     172.16.0.10
Máscara de subred:      255.255.255.0
Default Gateway:         172.16.0.1

PC4
IP:                                     172.16.1.10
Máscara de subred:      255.255.255.0
Default Gateway:         172.16.1.1

PC5
IP:                                     172.16.2.10
Máscara de subred:      255.255.255.0
Default Gateway:                        172.16.2.1


2.3.6 Pruebas de conexión

Ping desde PC0 a PC1, PC2, PC3, PC4 y PC5
Ping desde PC1 a PC0, PC2, PC3, PC4 y PC5
Ping desde PC2 a PC0, PC1, PC3, PC4 y PC5
Ping desde PC3 a PC0, PC1, PC2, PC4 y PC5
Ping desde PC4 a PC0, PC1, PC2, PC3 y PC5
Ping desde PC5 a PC0, PC1, PC3, PC3 y PC4

Ejemplo Ping desde PC0 a PC1 à Exitoso
C:\>ping 192.168.0.42
Pinging 192.168.0.42 with 32 bytes of data:
Reply from 192.168.0.42: bytes=32 time=1ms TTL=127
Reply from 192.168.0.42: bytes=32 time<1ms TTL=127
Reply from 192.168.0.42: bytes=32 time<1ms TTL=127
Reply from 192.168.0.42: bytes=32 time<1ms TTL=127
Ping statistics for 192.168.0.42:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 1ms, Average = 0ms


2.3.7 Comandos de troubleshooting

·        Sh ip interface brief
·        Sh run
·        sh ip route


2.3.7.1 Resultados Router1

Router1#show ip interface brief
Interface                            IP-Address          OK? Method       Status                                 Protocol
FastEthernet0/0               192.168.0.1        YES manual         up                                        up
FastEthernet0/1               192.168.0.33      YES manual         up                                        up
Serial0/0                            192.168.0.57      YES manual         up                                        up
FastEthernet1/0               192.168.0.49      YES manual         up                                        up
FastEthernet1/1               unassigned         YES unset            administratively down    down




Router1#sh run

Building configuration...
Current configuration : 822 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router1
!

no ip cef
no ipv6 cef
!
interface FastEthernet0/0
ip address 192.168.0.1 255.255.255.224
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.0.33 255.255.255.240
duplex auto
speed auto
!
interface Serial0/0
ip address 192.168.0.57 255.255.255.252
clock rate 2000000
!
interface FastEthernet1/0
ip address 192.168.0.49 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
duplex auto
speed auto
shutdown
!
ip classless
ip route 172.16.0.0 255.255.252.0 192.168.0.58
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
end


Router1# sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/22 is subnetted, 1 subnets
S       172.16.0.0 [1/0] via 192.168.0.58
     192.168.0.0/24 is variably subnetted, 4 subnets, 4 masks
C       192.168.0.0/27 is directly connected, FastEthernet0/0
C       192.168.0.32/28 is directly connected, FastEthernet0/1
C       192.168.0.48/29 is directly connected, FastEthernet1/0
C       192.168.0.56/30 is directly connected, Serial0/0


2.3.7.2 Resultados Router2

Router2#sh ip interface brief
Interface                             IP-Address          OK? Method                     Status                Protocol
FastEthernet0/0                172.16.0.1          YES manual                      up                    up
FastEthernet0/1                172.16.1.1          YES manual                      up                    up
Serial0/0                              192.168.0.58    YES manual                       up                    up
FastEthernet1/0               172.16.2.1           YES manual                      up                    up
FastEthernet1/1                unassigned         YES unset                          administratively down down


Router2#sh run

Router2#sh run
Building configuration...

Current configuration : 794 bytes
!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router2
!
no ip cef
no ipv6 cef
!
interface FastEthernet0/0
 ip address 172.16.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 192.168.0.58 255.255.255.252
interface FastEthernet1/0
 ip address 172.16.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/1
 no ip address
 duplex auto
 speed auto
 shutdown
!
ip classless
ip route 192.168.0.0 255.255.255.192 192.168.0.57
!
ip flow-export version 9
!
line con 0
!
line aux 0
!
line vty 0 4
 login
!
end


Router2#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 3 subnets
C       172.16.0.0 is directly connected, FastEthernet0/0
C       172.16.1.0 is directly connected, FastEthernet0/1
C       172.16.2.0 is directly connected, FastEthernet1/0
     192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
S       192.168.0.0/26 [1/0] via 192.168.0.57
C       192.168.0.56/30 is directly connected, Serial0/0



Cualquier duda, solo escribela en este blog y será respondida.

Para un curso completo sobre direccionamiento IP, puedes encontrar un descuento acá





Síguenos también en:


Facebook | Twitter | Google + Youtube Cursos





Regístrate a nuestros contenidos

* indicates required