martes, 21 de febrero de 2017

Configurar y verificar la conectividad de single-homed branch usando IPv4 eBGP (CCNA 200-125)


Configurar y verificar la conectividad de single-homed branch usando IPv4 eBGP (CCNA 200-125)


Diagrama







Objetivos

  • Configuración de eBGP
  • Verificar conectividad
  • Revisión de comandos para verificar y solucionar problemas eBGP


Conceptos

  • BGP ( Border Gateway Protocol), se define en el RFC 1771 , y es un protocolo que se utilizan en los nodos de Internet el cual intercambian información de encaminamiento o ruteo entre sistemas autónomos (AS). 
  • Un sistema autónomo es un conjunto de routers bajo una sola administración técnica
  • BGP tiene como misión encontrar el camino más eficiente entre los nodos para propiciar una correcta circulación de la información en Internet.
  • Dos routers cualquiera que formen una conexión TCP para intercambiar información de enrutamiento BGP son "pares" o "vecinos“
  • Cuando BGP se ejecuta entre routers que pertenecen a dos AS diferentes, recibe el nombre de BGP externo (eBGP). Cuando BGP se ejecuta entre routers del mismo AS, recibe el nombre de iBGP.

Configuración – Tabla Direccionamiento IP







Configuración Router1

  • Router1(config)# interface Loopback0
  • Router1(config-if)# ip address 1.1.1.1 255.255.255.0
  • Router1(config-if)# interface GigabitEthernet0/0
  • Router1(config-if)# ip address 1.1.2.1 255.255.255.252 
  • Router1(config)# router bgp 100
  • Router1(config)# neighbor 1.1.2.2 remote-as 200
  • Router1(config)# network 1.1.1.0 mask 255.255.255.0
  • Router1(config)# exit
  • Router1# copy run star

Configuración Router2

  • Router2(config)# interface Loopback0
  • Router2(config-if)# ip address 1.1.3.3 255.255.255.0
  • Router2(config-if)# interface GigabitEthernet0/0
  • Router2(config-if)# ip address 1.1.2.2 255.255.255.252 
  • Router2(config)# router bgp 200
  • Router2(config)# neighbor 1.1.2.1 remote-as 200
  • Router2(config)# network 1.1.3.0 mask 255.255.255.0
  • Router2(config)# exit
  • Router2# copy run star


Verificación de conectividad

  • Ping desde Router1 a Router2 (1.1.3.3)
  • Ping desde Router2 a Router1 (1.1.1.1)
Resultados, con respuesta satisfactoria:
Router1#ping 1.1.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms

Router2#ping 1.1.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/1 ms


Revisión de comandos para verificar y solucionar problemas de eBGP

  • show ip bgp
  • show ip bgp neighbors
  • show ip bgp summary
  • show ip route bgp
Resultados de verificación:
Router1#sh ip bgp
BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.0/24 0.0.0.0 0 0 32768 i
*> 1.1.3.0/24 1.1.2.2 0 0 0 200 i 


Router1#sh ip bgp neighbors
BGP neighbor is 1.1.2.2,  remote AS 200, external link
  BGP version 4, remote router ID 1.1.3.3
  BGP state = Established, up for 00:10:39
  Last read 00:10:39, last write 00:10:39, hold time is 180, keepalive interval is 60 seconds
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    Address family IPv4 Unicast: advertised and received
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                1          1
    Keepalives:            11         11
    Route Refresh:          0          0
    Total:                 13         13
  Default minimum time between advertisements runs is 30 seconds
 For address family: IPv4 Unicast
  BGP table version 3, neighbor version 6/0
  Output queue size : 0
  Index 1, Offset 0, Mask 0x2
  1 update-group member
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               1          1 (Consumes 46 bytes)
    Prefixes total:                 1          1
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          1
    Used as multipath:            n/a          0
                                       Outbound    Inbound
      Local Policy Denied Prefixes:    --------    -------
        Total:                                0          0
      Number of NLRIs in the update sent: max 3, min 1
  Address tracking is enabled, the RIB does have a route to 1.1.2.2
  Connections established 1; dropped 0
  Last reset never
  Transport(tcp) path-mtu-discovery is enabled
Connection state is ESTAB, I/O status: 1, unread input bytes: 0
Connection is ECN Disabled, Minimum incoming TTL 0, Outgoing TTL 1
Local host: 1.1.2.1, Local port: 179
Foreign host: 1.1.2.2, Foreign port: 1025
Connection tableid (VRF): 0
Enqueued packets for retransmit: 0, input: 0  mis-ordered: 0 (0 bytes)
Event Timers (current time is 0xC69F4):
Timer          Starts    Wakeups            Next
Retrans             0          0             0x0
TimeWait            0          0             0x0
AckHold            12          0             0x0
SendWnd             0          0             0x0
KeepAlive          11          0             0x0
GiveUp              0          0             0x0
PmtuAger            0          0             0x0
DeadWait            0          0             0x0
Linger              0          0             0x0
ProcessQ            0          0             0x0
iss: 2057115318  snduna: 2057115748  sndnxt: 2057115748     sndwnd:  15955
irs: 3480424370  rcvnxt: 3480424751  rcvwnd:      16004  delrcvwnd:    380
SRTT: 259 ms, RTTO: 579 ms, RTV: 320 ms, KRTT: 0 ms
minRTT: 16 ms, maxRTT: 300 ms, ACK hold: 200 ms
Status Flags: passive open, gen tcbs
Option Flags: nagle, path mtu capable
IP Precedence value : 6
Datagrams (max data segment is 1460 bytes):
Rcvd: 13 (out of order: 0), with data: 0, total data bytes: 0
Sent: 12 (retransmit: 0, fastretransmit: 0, partialack: 0, Second Congestion: 0), with data: 1, total data bytes: 24
 Packets received in fast path: 0, fast processed: 0, slow path: 0
 fast lock acquisition failures: 0, slow path: 0 

Router1#sh ip bgp summary
BGP router identifier 1.1.1.1, local AS number 100
BGP table version is 3, main routing table version 6
2 network entries using 264 bytes of memory
2 path entries using 104 bytes of memory
1/1 BGP path/bestpath attribute entries using 184 bytes of memory
2 BGP AS-PATH entries using 48 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 632 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor V AS MsgRcvd MsgSent TblVer  InQ OutQ Up/Down    State/PfxRcd
1.1.2.2      4 200       15             14     3            0      0          00:12:05        4

Router1#sh ip route bgp
B     1.1.3.0/24         [20/0]        via         1.1.2.2,    00:14:49



Cualquier duda, solo escribela en este blog y será respondida.

Para un curso completo sobre este tópico y otros del CCNA 200-125, puedes encontrarlo acá





Síguenos también en:


Facebook | Twitter | Google + Youtube Cursos





Regístrate a nuestros contenidos

* indicates required